use strict;
my $str = '
changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change
checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver
cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName
collapseList(pMultiList)
continueScript(pMsgStr)
convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert
convertISOtoDate(pDateStr) -- @Date @ISO @String
convertToDate(pDate) -- @Date @Convert @String
copyHTMLasRTFtoClipboard(pstrHTML)
createAliasIcon(pstrIconFile)
createHTMLLink for Params -- Params is a record
doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC
existsFinderItem(pPathStr)
expandPath(pPOSIXPath)
extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim
';
my $regex = qr/^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}