$re = '/^([^\(\n]+)\(([^\)]*)\)(?:\s+--\s+(.*))?$/m';
$str = '
changeDate(pPOSIXPath, pDateToChange, pNewDate) -- @Date @Finder @File @Change
checkReqdASVer(pVerReqdStr) -- @AppleScript @Ver
cleanName(pNameFinderItem) -- @Clean @File @Folder @Invalid @RegEx @Satimage @FileName
collapseList(pMultiList)
continueScript(pMsgStr)
convertASDateToNSDate(pASDate) -- @Date @NS @ASObjC @Convert
convertISOtoDate(pDateStr) -- @Date @ISO @String
convertToDate(pDate) -- @Date @Convert @String
copyHTMLasRTFtoClipboard(pstrHTML)
createAliasIcon(pstrIconFile)
createHTMLLink for Params -- Params is a record
doesItemExist(pPOSIXPath) -- @Path @File @Finder @ASObjC
existsFinderItem(pPathStr)
expandPath(pPOSIXPath)
extractIndex(pList, pStartDelim, pEndDelim) -- @List @Index @Delim
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);