import Foundation
let pattern = #"\{NUMBER(?<format>\:[^\}]*)?\}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{0$1}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)