import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{NUMBER(?<format>\\:[^\\}]*)?\\}";
final String string = "ZNK{NUMBER:D10}\n"
+ "ZNK{NUMBER}\n"
+ "ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ";
final String subst = "{0$1}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}