package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{NUMBER(?<format>\:[^\}]*)?\}`)
var str = `ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ`
var substitution = "{0$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}