$re = '/\{NUMBER(?<format>\:[^\}]*)?\}/m';
$str = 'ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ';
$subst = "{0$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;