use strict;
my $str = 'ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ';
my $regex = qr/\{NUMBER(?<format>\:[^\}]*)?\}/mp;
my $subst = '{0$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";