re = /\{NUMBER(?<format>\:[^\}]*)?\}/m
str = 'ZNK{NUMBER:D10}
ZNK{NUMBER}
ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ'
subst = '{0$1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result