re = /^[\p{Lu}][\p{Ll}]+$/m
str = 'Jevgēnijs
Blaus
blaus
Ab_sa
abRa
Abra
AbRa
Samuel
SamUel
SamSar
_As
_as
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end