$re = '/^[\p{Lu}][\p{Ll}]+$/mu';
$str = 'Jevgēnijs
Blaus
blaus
Ab_sa
abRa
Abra
AbRa
Samuel
SamUel
SamSar
_As
_as
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);