import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\p{Lu}][\\p{Ll}]+$";
final String string = "Jevgēnijs\n"
+ "Blaus\n"
+ "blaus\n"
+ "Ab_sa\n"
+ "abRa\n"
+ "Abra\n"
+ "AbRa\n"
+ "Samuel\n"
+ "SamUel\n"
+ "SamSar\n"
+ "_As\n"
+ "_as\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}