#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^[\p{Lu}][\p{Ll}]+$"
Local $sString = "Jevgēnijs" & @CRLF & _
"Blaus" & @CRLF & _
"blaus" & @CRLF & _
"Ab_sa" & @CRLF & _
"abRa" & @CRLF & _
"Abra" & @CRLF & _
"AbRa" & @CRLF & _
"Samuel" & @CRLF & _
"SamUel" & @CRLF & _
"SamSar" & @CRLF & _
"_As" & @CRLF & _
"_as" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")