package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{Lu}][\p{Ll}]+$`)
var str = `Jevgēnijs
Blaus
blaus
Ab_sa
abRa
Abra
AbRa
Samuel
SamUel
SamSar
_As
_as
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}