using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\p{Lu}][\p{Ll}]+$";
string input = @"Jevgēnijs
Blaus
blaus
Ab_sa
abRa
Abra
AbRa
Samuel
SamUel
SamSar
_As
_as
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}