import Foundation
let pattern = #"(\<)([A-Za-z0-9_!]+)(.*?)(\>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<html>
<body>
<h1>Aqui cabeçalho do arquivo</h1>
<p>Meu parágrafo da página web.</p>
<p>Meu segundo parágrafo.</p>
</body>
</html>
<p>
<html></html>
<!DOCTYPE>
<input href=""/>
<button type="submit"></button>
<button></button>
Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo.
<br/>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)