const regex = /(\<)([A-Za-z0-9_!]+)(.*?)(\>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\<)([A-Za-z0-9_!]+)(.*?)(\\>)', 'gm')
const str = `<html>
<body>
<h1>Aqui cabeçalho do arquivo</h1>
<p>Meu parágrafo da página web.</p>
<p>Meu segundo parágrafo.</p>
</body>
</html>
<p>
<html></html>
<!DOCTYPE>
<input href=""/>
<button type="submit"></button>
<button></button>
Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo.
<br/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}