import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<)([A-Za-z0-9_!]+)(.*?)(\\>)";
final String string = "<html>\n"
+ "<body>\n"
+ "<h1>Aqui cabeçalho do arquivo</h1>\n"
+ "<p>Meu parágrafo da página web.</p>\n"
+ "<p>Meu segundo parágrafo.</p>\n"
+ "</body>\n"
+ "</html>\n"
+ "<p>\n\n"
+ "<html></html>\n\n"
+ "<!DOCTYPE>\n"
+ "<input href=\"\"/>\n"
+ "<button type=\"submit\"></button>\n"
+ "<button></button>\n\n\n"
+ "Aenean lacinia bibendum <a href=\"/life\">life</a> sed consectetur. <a href=\"/work\">Work</a> quis risus eget urna mollis ornare <a href=\"/about\">about</a> leo.\n\n"
+ "<br/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}