#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\<)([A-Za-z0-9_!]+)(.*?)(\>)"
Local $sString = "<html>" & @CRLF & _
"<body>" & @CRLF & _
"<h1>Aqui cabeçalho do arquivo</h1>" & @CRLF & _
"<p>Meu parágrafo da página web.</p>" & @CRLF & _
"<p>Meu segundo parágrafo.</p>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
"<p>" & @CRLF & _
"" & @CRLF & _
"<html></html>" & @CRLF & _
"" & @CRLF & _
"<!DOCTYPE>" & @CRLF & _
"<input href=""/>" & @CRLF & _
"<button type="submit"></button>" & @CRLF & _
"<button></button>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo." & @CRLF & _
"" & @CRLF & _
"<br/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")