re = /(\<)([A-Za-z0-9_!]+)(.*?)(\>)/m
str = '<html>
<body>
<h1>Aqui cabeçalho do arquivo</h1>
<p>Meu parágrafo da página web.</p>
<p>Meu segundo parágrafo.</p>
</body>
</html>
<p>
<html></html>
<!DOCTYPE>
<input href=""/>
<button type="submit"></button>
<button></button>
Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo.
<br/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end