using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\<)([A-Za-z0-9_!]+)(.*?)(\>)";
string input = @"<html>
<body>
<h1>Aqui cabeçalho do arquivo</h1>
<p>Meu parágrafo da página web.</p>
<p>Meu segundo parágrafo.</p>
</body>
</html>
<p>
<html></html>
<!DOCTYPE>
<input href=""/>
<button type=""submit""></button>
<button></button>
Aenean lacinia bibendum <a href=""/life"">life</a> sed consectetur. <a href=""/work"">Work</a> quis risus eget urna mollis ornare <a href=""/about"">about</a> leo.
<br/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}