import Foundation
let pattern = #"^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)