const regex = /^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$', 'g')
const str = `c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}