// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$").unwrap();
let string = "c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}