using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$";
string input = @"c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}