package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$`)
var str = `c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}