re = /^[a-z0-9]{8}(?:-[a-z0-9]{4}){3}-[a-z0-9]{12}$/
str = 'c3d3c6e3-901a-4fcd-9d9f-c78bacf631f4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end