import Foundation
let pattern = #"(?<![final|import])static(?!\s*final)(?!.*{)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public static final String
final static String
static String
static String
static final String
static final String
import static org.
private static boolean someMethod() {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)