re = /(?<![final|import])static(?!\s*final)(?!.*{)/
str = 'public static final String
final static String
static String
static String
static final String
static final String
import static org.
private static boolean someMethod() {'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end