#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![final|import])static(?!\s*final)(?!.*{)"
Local $sString = "public static final String" & @CRLF & _
"final static String" & @CRLF & _
"static String" & @CRLF & _
" static String" & @CRLF & _
"static final String" & @CRLF & _
"static final String" & @CRLF & _
"import static org." & @CRLF & _
"private static boolean someMethod() {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")