const regex = /(?<![final|import])static(?!\s*final)(?!.*{)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![final|import])static(?!\\s*final)(?!.*{)', 'g')
const str = `public static final String
final static String
static String
static String
static final String
static final String
import static org.
private static boolean someMethod() {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}