import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![final|import])static(?!\\s*final)(?!.*\\{)";
final String string = "public static final String\n"
+ "final static String\n"
+ "static String\n"
+ " static String\n"
+ "static final String\n"
+ "static final String\n"
+ "import static org.\n"
+ "private static boolean someMethod() {";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}