$re = '/(?<![final|import])static(?!\s*final)(?!.*{)/';
$str = 'public static final String
final static String
static String
static String
static final String
static final String
import static org.
private static boolean someMethod() {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);