# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)"
test_str = ("Overlord Vol. 1: The Undead King\n"
"Overlord, Volume 1: The Undead King\n"
"Overlord, Vol 1: The Undead King\n"
"Overlord, Vol1: The Undead King\n"
"Overlord Vol1: The Undead King\n"
"Overlord: Volume 1: The Undead King\n"
"Overlord- Volume 1: The Undead King\n"
"Overlord Vol1: The Undead King\n"
"Overlord Vol 45\n"
"Overlord Vol 02\n"
"The Bad Volume are too high\n"
"Overlord Vol12: The Undead King\n"
"Overlord - Volume 17")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.