using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)";
string input = @"Overlord Vol. 1: The Undead King
Overlord, Volume 1: The Undead King
Overlord, Vol 1: The Undead King
Overlord, Vol1: The Undead King
Overlord Vol1: The Undead King
Overlord: Volume 1: The Undead King
Overlord- Volume 1: The Undead King
Overlord Vol1: The Undead King
Overlord Vol 45
Overlord Vol 02
The Bad Volume are too high
Overlord Vol12: The Undead King
Overlord - Volume 17";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}