const regex = new RegExp('Overlord([^\\w])+(\\w+)([^\\w]+|)([0-9])+(\\W*)', 'gm')
const str = `Overlord Vol. 1: The Undead King
Overlord, Volume 1: The Undead King
Overlord, Vol 1: The Undead King
Overlord, Vol1: The Undead King
Overlord Vol1: The Undead King
Overlord: Volume 1: The Undead King
Overlord- Volume 1: The Undead King
Overlord Vol1: The Undead King
Overlord Vol 45
Overlord Vol 02
The Bad Volume are too high
Overlord Vol12: The Undead King
Overlord - Volume 17`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}