import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Overlord([^\\w])+(\\w+)([^\\w]+|)([0-9])+(\\W*)";
final String string = "Overlord Vol. 1: The Undead King\n"
+ "Overlord, Volume 1: The Undead King\n"
+ "Overlord, Vol 1: The Undead King\n"
+ "Overlord, Vol1: The Undead King\n"
+ "Overlord Vol1: The Undead King\n"
+ "Overlord: Volume 1: The Undead King\n"
+ "Overlord- Volume 1: The Undead King\n"
+ "Overlord Vol1: The Undead King\n"
+ "Overlord Vol 45\n"
+ "Overlord Vol 02\n"
+ "The Bad Volume are too high\n"
+ "Overlord Vol12: The Undead King\n"
+ "Overlord - Volume 17";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}