package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)`)
var str = `Overlord Vol. 1: The Undead King
Overlord, Volume 1: The Undead King
Overlord, Vol 1: The Undead King
Overlord, Vol1: The Undead King
Overlord Vol1: The Undead King
Overlord: Volume 1: The Undead King
Overlord- Volume 1: The Undead King
Overlord Vol1: The Undead King
Overlord Vol 45
Overlord Vol 02
The Bad Volume are too high
Overlord Vol12: The Undead King
Overlord - Volume 17`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}