#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Overlord([^\w])+(\w+)([^\w]+|)([0-9])+(\W*)"
Local $sString = "Overlord Vol. 1: The Undead King" & @CRLF & _
"Overlord, Volume 1: The Undead King" & @CRLF & _
"Overlord, Vol 1: The Undead King" & @CRLF & _
"Overlord, Vol1: The Undead King" & @CRLF & _
"Overlord Vol1: The Undead King" & @CRLF & _
"Overlord: Volume 1: The Undead King" & @CRLF & _
"Overlord- Volume 1: The Undead King" & @CRLF & _
"Overlord Vol1: The Undead King" & @CRLF & _
"Overlord Vol 45" & @CRLF & _
"Overlord Vol 02" & @CRLF & _
"The Bad Volume are too high" & @CRLF & _
"Overlord Vol12: The Undead King" & @CRLF & _
"Overlord - Volume 17"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")