re = /(?![94]{2,2})(\d{1,10}$)/m
str = 'ФП75123
ФП123
94123
9412345
1601001234
101601001234
N/A1234
N/A12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end