#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?![94]{2,2})(\d{1,10}$)"
Local $sString = "ФП75123" & @CRLF & _
"ФП123" & @CRLF & _
"94123" & @CRLF & _
"9412345" & @CRLF & _
"1601001234" & @CRLF & _
"101601001234" & @CRLF & _
"N/A1234" & @CRLF & _
"N/A12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")