import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![94]{2,2})(\\d{1,10}$)";
final String string = "ФП75123\n"
+ "ФП123\n"
+ "94123\n"
+ "9412345\n"
+ "1601001234\n"
+ "101601001234\n"
+ "N/A1234\n"
+ "N/A12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}