using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![94]{2,2})(\d{1,10}$)";
string input = @"ФП75123
ФП123
94123
9412345
1601001234
101601001234
N/A1234
N/A12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}