$re = '/(?![94]{2,2})(\d{1,10}$)/m';
$str = 'ФП75123
ФП123
94123
9412345
1601001234
101601001234
N/A1234
N/A12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);