const regex = /(?![94]{2,2})(\d{1,10}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![94]{2,2})(\\d{1,10}$)', 'gm')
const str = `ФП75123
ФП123
94123
9412345
1601001234
101601001234
N/A1234
N/A12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}