import Foundation
let pattern = #"(["\'`])((\s|((\\)*)\\.|.)*?)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Catch quotes</title>
</head>
<body>
<Page data-info='Nobody\'s fool' />
<CodeCopier text=`
<h2>It is a</h2>
<h3>functional component</h3>
`>
<h1>Hello World!</h1>
</CodeCopier>
</body>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)