import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"\\'`])((\\s|((\\\\)*)\\\\.|.)*?)\\1";
final String string = "<!DOCTYPE html>\n"
+ " <html>\n"
+ " <head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <title>Catch quotes</title>\n"
+ " </head>\n"
+ " <body>\n"
+ " <Page data-info='Nobody\\'s fool' />\n"
+ " <CodeCopier text=`\n"
+ " <h2>It is a</h2>\n"
+ " <h3>functional component</h3>\n"
+ " `>\n"
+ " <h1>Hello World!</h1>\n"
+ " </CodeCopier>\n"
+ " </body>\n"
+ " </html>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}