use strict;
my $str = '<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Catch quotes</title>
</head>
<body>
<Page data-info=\'Nobody\\\'s fool\' />
<CodeCopier text=`
<h2>It is a</h2>
<h3>functional component</h3>
`>
<h1>Hello World!</h1>
</CodeCopier>
</body>
</html>
';
my $regex = qr/(["\'`])((\s|((\\)*)\\.|.)*?)\1/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}