const regex = /(["\'`])((\s|((\\)*)\\.|.)*?)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(["\\\'`])((\\s|((\\\\)*)\\\\.|.)*?)\\1', 'g')
const str = `<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Catch quotes</title>
</head>
<body>
<Page data-info='Nobody\\'s fool' />
<CodeCopier text=\`
<h2>It is a</h2>
<h3>functional component</h3>
\`>
<h1>Hello World!</h1>
</CodeCopier>
</body>
</html>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}