#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(["\'`])((\s|((\\)*)\\.|.)*?)\1"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
" <html>" & @CRLF & _
" <head>" & @CRLF & _
" <meta charset="UTF-8">" & @CRLF & _
" <title>Catch quotes</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <Page data-info='Nobody\'s fool' />" & @CRLF & _
" <CodeCopier text=`" & @CRLF & _
" <h2>It is a</h2>" & @CRLF & _
" <h3>functional component</h3>" & @CRLF & _
" `>" & @CRLF & _
" <h1>Hello World!</h1>" & @CRLF & _
" </CodeCopier>" & @CRLF & _
" </body>" & @CRLF & _
" </html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")