$re = '/(["\'`])((\s|((\\\\)*)\\\\.|.)*?)\1/';
$str = '<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>Catch quotes</title>
</head>
<body>
<Page data-info=\'Nobody\\\'s fool\' />
<CodeCopier text=`
<h2>It is a</h2>
<h3>functional component</h3>
`>
<h1>Hello World!</h1>
</CodeCopier>
</body>
</html>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);